Please update your browser's security settings.
To maintain the highest security standards, we will be disabling support for browsers using TLS 1.0. Learn more and upgrade your browser here.

 
Awareness Courses Online

Bloodborne Pathogens in Healthcare Facilities



This interactive course on Bloodborne Pathogens in Healthcare Facilities has been specifically created to assist facilities in fulfilling the OSHA Bloodborne Pathogens Standard's (29 CFR Part 1910.1030) training requirements.

Bloodborne diseases are a serious concern in the United States. Hepatitis B infects over 70,000 people annually, and has over one million carriers in the U. S. The HIV virus, which usually leads to AIDS, currently infects over one million people.  Because of the increasing problems with these diseases, in 1991 OSHA passed a Bloodborne Pathogens regulation. Areas covered in the course include the contents of the standard, epidemiology and symptoms of bloodborne diseases, modes by which bloodborne diseases are transmitted, the exposure control plan, recognition of exposure situations, practices to prevent exposure, HBV vaccine, emergency procedures, signs and labels, selection and use of personal protective equipment, and more.

Using a powerful combination of audio, full-motion video, text and colorful graphics, this course provides the most cost-effective safety and regulatory compliance training available today.  The course is divided into a number of logical sections so information is easily understood... and retained.
Details
Bloodborne Pathogens in Healthcare Facilities Online Training
$19.95 CAD

Purchase Now

Employers:

To purchase multiple courses click below to create a Corporate Account.

  • Manage student accounts
  • Review training records
  • Bulk pricing discounts!
 
90 minute runtime (average)
Canadian government standards compliant
Rich multi-media modules
Dynamically generated exams
Personalized wallet certificate upon completion

Course Compatibility


Operating Systems/Internet Browsers
*Review the chart above for your OS and browser

Windows Vista, 7, 8, 10
Mac OS X – 10.0+
Linux
Google Chrome All Versions
Internet Explorer Version 9+
Mozilla Firefox Version 3.5+
Safari Version 7.0+